PassMe Support for New DS Firmware

Logo

Natrium has updated his weblog with the following information:

New DSes seem to be shipped with new firmware that makes current PassMe not work. Loopy figured out how to circumvent the new protection, but the exploit is DS card specific and requires SRAM in the GBA slot (i.e. GBAMP won’t work). I can probably fit in support for about four cards into a single PassMe. Also, there will be PassMes with different sets of supported games.

So what I need people to do right now is to run the attached .ds.gba on bootable DSes using different DS cards and tell me the numbers on the screen. This will help me add support for those cards.

You need to run this from a GBA flashcard without any use of DS menu loaders, since they might clear or corrupt the memory that is being searched for the exploit. Consequently, there is no .nds version of the program.

Some PassMes (or clones) are not supported, because a specific bit in the header is set, resulting in scrambled memory. This bit doesn’t affect homebrew in any way, but it makes it impossible to explore memory left over from loading a DS card. This program will tell when a PassMe (or clone) is not supported.

Please post your results [here] or email them to me. I will then add support for most popular games and put new PassMes up for sale.

Note: This program will whitescreen for a while before showing numbers. This is normal, since searching takes some time.

You can get it in our NDS Download section [here].

Logo

Natrium has updated his weblog with the following information:

New DSes seem to be shipped with new firmware that makes current PassMe not work. Loopy figured out how to circumvent the new protection, but the exploit is DS card specific and requires SRAM in the GBA slot (i.e. GBAMP won’t work). I can probably fit in support for about four cards into a single PassMe. Also, there will be PassMes with different sets of supported games.

So what I need people to do right now is to run the attached .ds.gba on bootable DSes using different DS cards and tell me the numbers on the screen. This will help me add support for those cards.

You need to run this from a GBA flashcard without any use of DS menu loaders, since they might clear or corrupt the memory that is being searched for the exploit. Consequently, there is no .nds version of the program.

Some PassMes (or clones) are not supported, because a specific bit in the header is set, resulting in scrambled memory. This bit doesn’t affect homebrew in any way, but it makes it impossible to explore memory left over from loading a DS card. This program will tell when a PassMe (or clone) is not supported.

Please post your results [here] or email them to me. I will then add support for most popular games and put new PassMes up for sale.

Note: This program will whitescreen for a while before showing numbers. This is normal, since searching takes some time.

You can get it in our NDS Download section [here].

Add a Comment

Your email address will not be published.