The Clear-Up: Does Vice City Stories play on 2.71?

Vice City Stories

We would like to start this article with a sincere apology and by admitting that yesterday’s article claiming that Grand Theft Auto: Vice City Stories required PSP firmware 2.81 was incorrect. We based this information on data we had obtained from what we thought was a trustworthy news source, but it appears we were wrong. The fact of the matter is that you can play Grand Theft Auto: Vice City Stories without updating to 2.81, using Booster‘s amazing DevHook. All you have to do is emulate firmware 2.71 and select the 2.xx to 2.00 UMD option and Grand Theft Auto: Vice City Stories will work fine. The 2.81 update is on the UMD disc, but you do not have to use it.

Discussion has been rife on this subject both in the comments section and in our forums, with many PSP owners confused on whether to buy Vice City Stories or not because of this. We have had it confirmed by many of our forum users that it works with 2.xx to 2.00 UMD option in DevHook and firmware 2.71 emulation. We are sorry for any inconvenience this may have caused you, but it was a mistake that we highly regret. Most of you will have probably discovered that VCS works on 2.71 with DevHook, but this post is an informative article and is an apology from us to you. How will we repay you? By giving you the best news 24/7 of course!

An 11-page discussion in our forums has been going on since yesterday, so if you want to get in on the action, all you have to do is head over to our forums. This may be an apology, but it is clear now that you can have Grand Theft Auto: Vice City Stories playable with homebrew on 1.5 and with Dark_Alex‘s 2.71 SE-B custom firmware using the miracles of DevHook. To me, that sounds like more of a success!

Discuss: [Forum Release Thread]
Buy: [Grand Theft Auto: Vice City Stories]

Vice City Stories

We would like to start this article with a sincere apology and by admitting that yesterday’s article claiming that Grand Theft Auto: Vice City Stories required PSP firmware 2.81 was incorrect. We based this information on data we had obtained from what we thought was a trustworthy news source, but it appears we were wrong. The fact of the matter is that you can play Grand Theft Auto: Vice City Stories without updating to 2.81, using Booster‘s amazing DevHook. All you have to do is emulate firmware 2.71 and select the 2.xx to 2.00 UMD option and Grand Theft Auto: Vice City Stories will work fine. The 2.81 update is on the UMD disc, but you do not have to use it.

Discussion has been rife on this subject both in the comments section and in our forums, with many PSP owners confused on whether to buy Vice City Stories or not because of this. We have had it confirmed by many of our forum users that it works with 2.xx to 2.00 UMD option in DevHook and firmware 2.71 emulation. We are sorry for any inconvenience this may have caused you, but it was a mistake that we highly regret. Most of you will have probably discovered that VCS works on 2.71 with DevHook, but this post is an informative article and is an apology from us to you. How will we repay you? By giving you the best news 24/7 of course!

An 11-page discussion in our forums has been going on since yesterday, so if you want to get in on the action, all you have to do is head over to our forums. This may be an apology, but it is clear now that you can have Grand Theft Auto: Vice City Stories playable with homebrew on 1.5 and with Dark_Alex‘s 2.71 SE-B custom firmware using the miracles of DevHook. To me, that sounds like more of a success!

Discuss: [Forum Release Thread]
Buy: [Grand Theft Auto: Vice City Stories]

Add a Comment

Your email address will not be published.